aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2020-08-27 08:13:11 +0200
committerDaniel Lange <DLange@git.local>2020-08-27 08:13:11 +0200
commited6a8b440c697fe861f33e7cae44e7853cd4dc31 (patch)
tree2001b7f34d1aab4700542fd64a0853dcb93ef29a
parent7a637ff1dea1a02a42e55aa79f03a9e85a576207 (diff)
downloaddebian_htop-ed6a8b440c697fe861f33e7cae44e7853cd4dc31.tar.gz
debian_htop-ed6a8b440c697fe861f33e7cae44e7853cd4dc31.tar.bz2
debian_htop-ed6a8b440c697fe861f33e7cae44e7853cd4dc31.zip
Drop Debian patches merged upstream (or fixed differently)
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/780-fix-option-string.patch23
-rw-r--r--debian/patches/close-pipe-after-lsof.patch15
-rw-r--r--debian/patches/fix-linux-process.patch13
-rw-r--r--debian/patches/gcc10.patch35
-rw-r--r--debian/patches/python3.patch13
-rw-r--r--debian/patches/series5
7 files changed, 8 insertions, 104 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d375ff..c0111dd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+htop (3.0.0-1) UNRELEASED; urgency=medium
+
+ * Switch upstream to htop-dev
+ * New upstream release 3.0.0
+ * Drop Debian patches merged upstream
+
+ -- Daniel Lange <DLange@debian.org> Thu, 27 Aug 2020 07:49:33 +0200
+
htop (2.2.0-3) unstable; urgency=medium
[ Graham Inggs ]
diff --git a/debian/patches/780-fix-option-string.patch b/debian/patches/780-fix-option-string.patch
deleted file mode 100644
index a827389..0000000
--- a/debian/patches/780-fix-option-string.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 731acc8bced18c90fbe0e18381c32f007f71e0d9 Mon Sep 17 00:00:00 2001
-From: Christian Hesse <mail@eworm.de>
-Date: Tue, 10 Apr 2018 16:21:46 +0200
-Subject: [PATCH] fix option string
-
-This broke with commit db05ba61065f64b59d0014518be0786b5439e54c.
----
- htop.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/htop.c b/htop.c
-index 6db81dd7..678a3b8a 100644
---- a/htop.c
-+++ b/htop.c
-@@ -93,7 +93,7 @@ static CommandLineSettings parseArguments(int argc, char** argv) {
-
- int opt, opti=0;
- /* Parse arguments */
-- while ((opt = getopt_long(argc, argv, "hvCst::d:u:p:i", long_opts, &opti))) {
-+ while ((opt = getopt_long(argc, argv, "hvCs:td:u:p:i", long_opts, &opti))) {
- if (opt == EOF) break;
- switch (opt) {
- case 'h':
diff --git a/debian/patches/close-pipe-after-lsof.patch b/debian/patches/close-pipe-after-lsof.patch
deleted file mode 100644
index e5cbf6f..0000000
--- a/debian/patches/close-pipe-after-lsof.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Description: Close pipe after lsof
-Forwarded: https://github.com/hishamhm/htop/pull/917
-Author: Jesin <Jesin00@gmail.com>
-Last-Update: 2019-06-23
-
---- a/OpenFilesScreen.c
-+++ b/OpenFilesScreen.c
-@@ -124,6 +124,7 @@
- item->data[cmd] = xStrdup(line + 1);
- free(line);
- }
-+ fclose(fd);
- int wstatus;
- if (waitpid(child, &wstatus, 0) == -1) {
- pdata->error = 1;
diff --git a/debian/patches/fix-linux-process.patch b/debian/patches/fix-linux-process.patch
deleted file mode 100644
index 3caef04..0000000
--- a/debian/patches/fix-linux-process.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Make sure the auto-regenerated headers (after scripts/MakeHeader.py) actually compile.
-
---- a/linux/LinuxProcess.c 2018-04-26 18:17:31.349248819 +0200
-+++ b/linux/LinuxProcess.c 2018-04-11 02:58:46.994360617 +0200
-@@ -143,7 +143,7 @@
- } LinuxProcess;
-
- #ifndef Process_isKernelThread
--#define Process_isKernelThread(_process) ((LinuxProcess*)(_process)->isKernelThread)
-+#define Process_isKernelThread(_process) (((LinuxProcess*)(_process))->isKernelThread)
- #endif
-
- #ifndef Process_isUserlandThread
diff --git a/debian/patches/gcc10.patch b/debian/patches/gcc10.patch
deleted file mode 100644
index 5487ffb..0000000
--- a/debian/patches/gcc10.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Description: Avoid FTBFS with GCC 10
- Initialize some pointers in CRT.c so that CRT.h is
- generated with the appropriate 'extern' keywords
-Bug: https://github.com/hishamhm/htop/issues/986
-Bug-Debian: https://bugs.debian.org/957344
-Author: Graham Inggs <ginggs@debian.org>
-Last-Update: 2020-07-02
-
---- a/CRT.c
-+++ b/CRT.c
-@@ -171,7 +171,7 @@
-
- int CRT_delay = 0;
-
--int* CRT_colors;
-+int* CRT_colors = NULL;
-
- int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT] = {
- [COLORSCHEME_DEFAULT] = {
-@@ -537,13 +537,13 @@
-
- int CRT_scrollWheelVAmount = 10;
-
--char* CRT_termType;
-+char* CRT_termType = NULL;
-
- // TODO move color scheme to Settings, perhaps?
-
- int CRT_colorScheme = 0;
-
--void *backtraceArray[128];
-+void *backtraceArray[128] = { NULL };
-
- static void CRT_handleSIGTERM(int sgn) {
- (void) sgn;
diff --git a/debian/patches/python3.patch b/debian/patches/python3.patch
deleted file mode 100644
index 6a65355..0000000
--- a/debian/patches/python3.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Description: Run MakeHeader.py in Python 3
-Forwarded: not-needed
-Author: Graham Inggs <ginggs@debian.org>
-Last-Update: 2019-07-22
-
---- a/scripts/MakeHeader.py
-+++ b/scripts/MakeHeader.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/python3
- import os, sys, string, io
- try:
- from StringIO import StringIO
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 7cbe4dc..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,5 +0,0 @@
-780-fix-option-string.patch
-fix-linux-process.patch
-python3.patch
-gcc10.patch
-close-pipe-after-lsof.patch

© 2014-2024 Faster IT GmbH | imprint | privacy policy