aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am238
1 files changed, 193 insertions, 45 deletions
diff --git a/Makefile.am b/Makefile.am
index fe70eef..81b9c93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,14 @@
-AUTOMAKE_OPTIONS = subdir-objects
-
-bin_PROGRAMS = htop
-
dist_man_MANS = htop.1
-EXTRA_DIST = $(dist_man_MANS) htop.desktop htop.png htop.svg \
-install-sh autogen.sh missing
+EXTRA_DIST = \
+ $(dist_man_MANS) \
+ autogen.sh \
+ htop.desktop \
+ htop.png \
+ htop.svg \
+ build-aux/compile \
+ build-aux/depcomp \
+ build-aux/install-sh \
+ build-aux/missing
applicationsdir = $(datadir)/applications
applications_DATA = htop.desktop
pixmapdir = $(datadir)/pixmaps
@@ -12,7 +16,7 @@ pixmap_DATA = htop.png
appicondir = $(datadir)/icons/hicolor/scalable/apps
appicon_DATA = htop.svg
-AM_CFLAGS += -pedantic -std=c99 -D_XOPEN_SOURCE_EXTENDED -DSYSCONFDIR=\"$(sysconfdir)\" -I"$(top_srcdir)/$(my_htop_platform)"
+AM_CFLAGS += -pedantic -std=c99 -D_XOPEN_SOURCE_EXTENDED -DSYSCONFDIR="\"$(sysconfdir)\"" -I"$(top_srcdir)/$(my_htop_platform)"
AM_LDFLAGS =
myhtopsources = \
@@ -26,6 +30,7 @@ myhtopsources = \
ClockMeter.c \
ColorsPanel.c \
ColumnsPanel.c \
+ CommandLine.c \
CommandScreen.c \
Compat.c \
CPUMeter.c \
@@ -34,18 +39,21 @@ myhtopsources = \
DateTimeMeter.c \
DiskIOMeter.c \
DisplayOptionsPanel.c \
+ DynamicColumn.c \
+ DynamicMeter.c \
EnvScreen.c \
FunctionBar.c \
Hashtable.c \
Header.c \
+ HeaderOptionsPanel.c \
HostnameMeter.c \
- htop.c \
IncSet.c \
InfoScreen.c \
ListItem.c \
LoadAverageMeter.c \
MainPanel.c \
MemoryMeter.c \
+ MemorySwapMeter.c \
Meter.c \
MetersPanel.c \
NetworkIOMeter.c \
@@ -61,6 +69,7 @@ myhtopsources = \
Settings.c \
SignalsPanel.c \
SwapMeter.c \
+ SysArchMeter.c \
TasksMeter.c \
TraceScreen.c \
UptimeMeter.c \
@@ -81,16 +90,21 @@ myhtopheaders = \
ClockMeter.h \
ColorsPanel.h \
ColumnsPanel.h \
+ CommandLine.h \
CommandScreen.h \
Compat.h \
DateMeter.h \
DateTimeMeter.h \
DiskIOMeter.h \
DisplayOptionsPanel.h \
+ DynamicColumn.h \
+ DynamicMeter.h \
EnvScreen.h \
FunctionBar.h \
Hashtable.h \
Header.h \
+ HeaderLayout.h \
+ HeaderOptionsPanel.h \
HostnameMeter.h \
IncSet.h \
InfoScreen.h \
@@ -99,6 +113,7 @@ myhtopheaders = \
Macros.h \
MainPanel.h \
MemoryMeter.h \
+ MemorySwapMeter.h \
Meter.h \
MetersPanel.h \
NetworkIOMeter.h \
@@ -115,6 +130,7 @@ myhtopheaders = \
Settings.h \
SignalsPanel.h \
SwapMeter.h \
+ SysArchMeter.h \
TasksMeter.h \
TraceScreen.h \
UptimeMeter.h \
@@ -126,6 +142,10 @@ myhtopheaders = \
# -----
linux_platform_headers = \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/uname.h \
+ linux/HugePageMeter.h \
linux/IOPriority.h \
linux/IOPriorityPanel.h \
linux/LibSensors.h \
@@ -142,9 +162,11 @@ linux_platform_headers = \
zfs/ZfsArcStats.h \
zfs/ZfsCompressedArcMeter.h
-if HTOP_LINUX
-AM_LDFLAGS += -rdynamic
-myhtopplatsources = \
+linux_platform_sources = \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/uname.c \
+ linux/HugePageMeter.c \
linux/IOPriorityPanel.c \
linux/LibSensors.c \
linux/LinuxProcess.c \
@@ -155,10 +177,13 @@ myhtopplatsources = \
linux/SystemdMeter.c \
linux/ZramMeter.c \
zfs/ZfsArcMeter.c \
- zfs/ZfsArcStats.c \
zfs/ZfsCompressedArcMeter.c
+if HTOP_LINUX
+AM_LDFLAGS += -rdynamic
+myhtopplatprogram = htop
myhtopplatheaders = $(linux_platform_headers)
+myhtopplatsources = $(linux_platform_sources)
endif
# FreeBSD
@@ -169,17 +194,29 @@ freebsd_platform_headers = \
freebsd/FreeBSDProcess.h \
freebsd/Platform.h \
freebsd/ProcessField.h \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/openzfs_sysctl.h \
+ generic/uname.h \
zfs/ZfsArcMeter.h \
- zfs/ZfsCompressedArcMeter.h \
zfs/ZfsArcStats.h \
- zfs/openzfs_sysctl.h
+ zfs/ZfsCompressedArcMeter.h
-if HTOP_FREEBSD
-myhtopplatsources = freebsd/Platform.c freebsd/FreeBSDProcessList.c \
-freebsd/FreeBSDProcess.c \
-zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c zfs/openzfs_sysctl.c
+freebsd_platform_sources = \
+ freebsd/Platform.c \
+ freebsd/FreeBSDProcessList.c \
+ freebsd/FreeBSDProcess.c \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/openzfs_sysctl.c \
+ generic/uname.c \
+ zfs/ZfsArcMeter.c \
+ zfs/ZfsCompressedArcMeter.c
+if HTOP_FREEBSD
+myhtopplatprogram = htop
myhtopplatheaders = $(freebsd_platform_headers)
+myhtopplatsources = $(freebsd_platform_sources)
endif
# DragonFlyBSD
@@ -189,31 +226,75 @@ dragonflybsd_platform_headers = \
dragonflybsd/DragonFlyBSDProcessList.h \
dragonflybsd/DragonFlyBSDProcess.h \
dragonflybsd/Platform.h \
- dragonflybsd/ProcessField.h
+ dragonflybsd/ProcessField.h \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/uname.h
-if HTOP_DRAGONFLYBSD
-myhtopplatsources = \
- dragonflybsd/Platform.c \
+dragonflybsd_platform_sources = \
dragonflybsd/DragonFlyBSDProcessList.c \
- dragonflybsd/DragonFlyBSDProcess.c
+ dragonflybsd/DragonFlyBSDProcess.c \
+ dragonflybsd/Platform.c \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/uname.c
+if HTOP_DRAGONFLYBSD
+myhtopplatprogram = htop
myhtopplatheaders = $(dragonflybsd_platform_headers)
+myhtopplatsources = $(dragonflybsd_platform_sources)
+endif
+
+# NetBSD
+# -------
+
+netbsd_platform_headers = \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/uname.h \
+ netbsd/Platform.h \
+ netbsd/ProcessField.h \
+ netbsd/NetBSDProcess.h \
+ netbsd/NetBSDProcessList.h
+
+netbsd_platform_sources = \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/uname.c \
+ netbsd/Platform.c \
+ netbsd/NetBSDProcess.c \
+ netbsd/NetBSDProcessList.c
+
+if HTOP_NETBSD
+myhtopplatprogram = htop
+myhtopplatheaders = $(netbsd_platform_headers)
+myhtopplatsources = $(netbsd_platform_sources)
endif
# OpenBSD
# -------
openbsd_platform_headers = \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/uname.h \
openbsd/OpenBSDProcessList.h \
openbsd/OpenBSDProcess.h \
openbsd/Platform.h \
openbsd/ProcessField.h
-if HTOP_OPENBSD
-myhtopplatsources = openbsd/Platform.c openbsd/OpenBSDProcessList.c \
-openbsd/OpenBSDProcess.c
+openbsd_platform_sources = \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/uname.c \
+ openbsd/OpenBSDProcessList.c \
+ openbsd/OpenBSDProcess.c \
+ openbsd/Platform.c
+if HTOP_OPENBSD
+myhtopplatprogram = htop
myhtopplatheaders = $(openbsd_platform_headers)
+myhtopplatsources = $(openbsd_platform_sources)
endif
# Darwin
@@ -224,59 +305,126 @@ darwin_platform_headers = \
darwin/DarwinProcessList.h \
darwin/Platform.h \
darwin/ProcessField.h \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/openzfs_sysctl.h \
+ generic/uname.h \
zfs/ZfsArcMeter.h \
- zfs/ZfsCompressedArcMeter.h \
zfs/ZfsArcStats.h \
- zfs/openzfs_sysctl.h
+ zfs/ZfsCompressedArcMeter.h
+
+darwin_platform_sources = \
+ darwin/Platform.c \
+ darwin/DarwinProcess.c \
+ darwin/DarwinProcessList.c \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/openzfs_sysctl.c \
+ generic/uname.c \
+ zfs/ZfsArcMeter.c \
+ zfs/ZfsCompressedArcMeter.c
if HTOP_DARWIN
AM_LDFLAGS += -framework IOKit -framework CoreFoundation
-myhtopplatsources = darwin/Platform.c darwin/DarwinProcess.c \
-darwin/DarwinProcessList.c \
-zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c zfs/openzfs_sysctl.c
-
+myhtopplatprogram = htop
myhtopplatheaders = $(darwin_platform_headers)
+myhtopplatsources = $(darwin_platform_sources)
endif
# Solaris
# -------
solaris_platform_headers = \
- solaris/Platform.h \
+ generic/gettime.h \
+ generic/hostname.h \
+ generic/uname.h \
solaris/ProcessField.h \
+ solaris/Platform.h \
solaris/SolarisProcess.h \
solaris/SolarisProcessList.h \
zfs/ZfsArcMeter.h \
- zfs/ZfsCompressedArcMeter.h \
- zfs/ZfsArcStats.h
+ zfs/ZfsArcStats.h \
+ zfs/ZfsCompressedArcMeter.h
-if HTOP_SOLARIS
-myhtopplatsources = solaris/Platform.c \
-solaris/SolarisProcess.c solaris/SolarisProcessList.c \
-zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c
+solaris_platform_sources = \
+ generic/gettime.c \
+ generic/hostname.c \
+ generic/uname.c \
+ solaris/Platform.c \
+ solaris/SolarisProcess.c \
+ solaris/SolarisProcessList.c \
+ zfs/ZfsArcMeter.c \
+ zfs/ZfsCompressedArcMeter.c
+if HTOP_SOLARIS
+myhtopplatprogram = htop
myhtopplatheaders = $(solaris_platform_headers)
+myhtopplatsources = $(solaris_platform_sources)
+endif
+
+# Performance Co-Pilot (PCP)
+# --------------------------
+
+pcp_platform_headers = \
+ linux/PressureStallMeter.h \
+ linux/ZramMeter.h \
+ linux/ZramStats.h \
+ pcp/PCPDynamicColumn.h \
+ pcp/PCPDynamicMeter.h \
+ pcp/PCPMetric.h \
+ pcp/PCPProcess.h \
+ pcp/PCPProcessList.h \
+ pcp/Platform.h \
+ pcp/ProcessField.h \
+ zfs/ZfsArcMeter.h \
+ zfs/ZfsArcStats.h \
+ zfs/ZfsCompressedArcMeter.h
+
+pcp_platform_sources = \
+ linux/PressureStallMeter.c \
+ linux/ZramMeter.c \
+ pcp/PCPDynamicColumn.c \
+ pcp/PCPDynamicMeter.c \
+ pcp/PCPMetric.c \
+ pcp/PCPProcess.c \
+ pcp/PCPProcessList.c \
+ pcp/Platform.c \
+ zfs/ZfsArcMeter.c \
+ zfs/ZfsCompressedArcMeter.c
+
+if HTOP_PCP
+myhtopplatprogram = pcp-htop
+myhtopplatheaders = $(pcp_platform_headers)
+myhtopplatsources = $(pcp_platform_sources)
+pcp_htop_SOURCES = $(myhtopplatprogram).c $(myhtopheaders) $(myhtopplatheaders) $(myhtopsources) $(myhtopplatsources)
endif
# Unsupported
# -----------
unsupported_platform_headers = \
+ generic/gettime.h \
unsupported/Platform.h \
unsupported/ProcessField.h \
unsupported/UnsupportedProcess.h \
unsupported/UnsupportedProcessList.h
-if HTOP_UNSUPPORTED
-myhtopplatsources = unsupported/Platform.c \
-unsupported/UnsupportedProcess.c unsupported/UnsupportedProcessList.c
+unsupported_platform_sources = \
+ generic/gettime.c \
+ unsupported/Platform.c \
+ unsupported/UnsupportedProcess.c \
+ unsupported/UnsupportedProcessList.c
+if HTOP_UNSUPPORTED
+myhtopplatprogram = htop
+myhtopplatsources = $(unsupported_platform_sources)
myhtopplatheaders = $(unsupported_platform_headers)
endif
# ----
-htop_SOURCES = $(myhtopheaders) $(myhtopplatheaders) $(myhtopsources) $(myhtopplatsources)
+bin_PROGRAMS = $(myhtopplatprogram)
+htop_SOURCES = $(myhtopplatprogram).c $(myhtopheaders) $(myhtopplatheaders) $(myhtopsources) $(myhtopplatsources)
nodist_htop_SOURCES = config.h
target:
@@ -286,10 +434,10 @@ profile:
$(MAKE) all AM_CPPFLAGS="-pg -O2 -DNDEBUG"
debug:
- $(MAKE) all AM_CPPFLAGS="-ggdb -DDEBUG"
+ $(MAKE) all AM_CPPFLAGS="-ggdb3 -Og" CFLAGS="`printf ' %s ' "$(CFLAGS)"|sed -E 's#[[:space:]]-O[^[:space:]]+[[:space:]]# #g'` -ggdb3 -Og"
coverage:
- $(MAKE) all AM_CPPFLAGS="-fprofile-arcs -ftest-coverage -DDEBUG" AM_LDFLAGS="-lgcov"
+ $(MAKE) all AM_CPPFLAGS="-fprofile-arcs -ftest-coverage" AM_LDFLAGS="-lgcov"
cppcheck:
cppcheck -q -v . --enable=all -DHAVE_OPENVZ

© 2014-2024 Faster IT GmbH | imprint | privacy policy