aboutsummaryrefslogtreecommitdiffstats
path: root/plpa-1.1/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2016-04-11 13:00:22 +0200
committerDaniel Lange <DLange@git.local>2016-04-11 13:00:22 +0200
commitc74c38760df69bb87e93dff18cf91464e5d02f37 (patch)
treeee2a19a0ef3a808bdfc8c1e6a00e96d79966dcb0 /plpa-1.1/src/Makefile.am
parent9379132a8234eeedf62d37ef57713e52c12db6ab (diff)
downloaddebian_htop-c74c38760df69bb87e93dff18cf91464e5d02f37.tar.gz
debian_htop-c74c38760df69bb87e93dff18cf91464e5d02f37.tar.bz2
debian_htop-c74c38760df69bb87e93dff18cf91464e5d02f37.zip
Imported Upstream version 0.8.1upstream/0.8.1
Diffstat (limited to 'plpa-1.1/src/Makefile.am')
-rw-r--r--plpa-1.1/src/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/plpa-1.1/src/Makefile.am b/plpa-1.1/src/Makefile.am
new file mode 100644
index 0000000..8819d88
--- /dev/null
+++ b/plpa-1.1/src/Makefile.am
@@ -0,0 +1,49 @@
+#
+# Copyright (c) 2004-2005 The Trustees of Indiana University and Indiana
+# University Research and Technology
+# Corporation. All rights reserved.
+# Copyright (c) 2004-2005 The University of Tennessee and The University
+# of Tennessee Research Foundation. All rights
+# reserved.
+# Copyright (c) 2004-2005 High Performance Computing Center Stuttgart,
+# University of Stuttgart. All rights reserved.
+# Copyright (c) 2004-2005 The Regents of the University of California.
+# All rights reserved.
+# Copyright (c) 2006-2007 Cisco Systems, Inc. All rights reserved.
+# $COPYRIGHT$
+#
+# Additional copyrights may follow
+#
+# $HEADER$
+#
+
+# Defaults
+lib_LTLIBRARIES =
+noinst_LTLIBRARIES =
+nodist_include_HEADERS =
+nodist_noinst_HEADERS =
+
+# Note that this file is generated by configure, so we don't want to
+# ship it in the tarball. Hence the "nodist_" prefixes to the HEADERS
+# macros, below.
+public_headers = plpa.h
+
+# See which mode we're building in
+if PLPA_BUILD_STANDALONE
+lib_LTLIBRARIES += libplpa.la
+nodist_include_HEADERS += $(public_headers)
+else
+noinst_LTLIBRARIES += libplpa_included.la
+nodist_noinst_HEADERS += $(public_headers)
+endif
+
+# The sources
+plpa_sources = \
+ plpa_internal.h \
+ plpa_api_probe.c \
+ plpa_dispatch.c \
+ plpa_runtime.c \
+ plpa_map.c
+
+libplpa_la_SOURCES = $(plpa_sources)
+libplpa_included_la_SOURCES = $(plpa_sources)

© 2014-2024 Faster IT GmbH | imprint | privacy policy