aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2020-09-03 12:34:39 +0200
committerDaniel Lange <DLange@git.local>2020-09-03 12:34:39 +0200
commit59eeadec918a955b40427a1b012992161050c939 (patch)
tree4d3a4708e29a6a2f8807b2843a3cbae99f5dfda3 /configure.ac
parentf3147ea2d1598914c2db53e8cfb34c8ff81e2ff4 (diff)
downloaddebian_htop-59eeadec918a955b40427a1b012992161050c939.tar.gz
debian_htop-59eeadec918a955b40427a1b012992161050c939.tar.bz2
debian_htop-59eeadec918a955b40427a1b012992161050c939.zip
New upstream version 3.0.1upstream/3.0.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 23 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 18291b9..f6498b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.65)
-AC_INIT([htop],[3.0.0],[htop@groups.io])
+AC_INIT([htop],[3.0.1],[htop@groups.io])
AC_CONFIG_SRCDIR([htop.c])
AC_CONFIG_AUX_DIR([.])
@@ -111,20 +111,12 @@ AC_SUBST(wextra_flag)
# ----------------------------------------------------------------------
PROCDIR=/proc
-AC_ARG_ENABLE(proc, [AS_HELP_STRING([--enable-proc], [use Linux-compatible proc filesystem])], enable_proc="yes", enable_proc="no")
-if test "x$enable_proc" = xyes; then
- # An enabled proc assumes we're emulating Linux.
- my_htop_platform=linux
- AC_DEFINE(HAVE_PROC, 1, [Define if using a Linux-compatible proc filesystem.])
-fi
-
AC_ARG_WITH(proc, [AS_HELP_STRING([--with-proc=DIR], [Location of a Linux-compatible proc filesystem (default=/proc).])],
-
-if test -n "$withval"; then
- AC_DEFINE_UNQUOTED(PROCDIR, "$withval", [Path of proc filesystem])
- PROCDIR="$withval"
-fi,
-AC_DEFINE(PROCDIR, "/proc", [Path of proc filesystem]))
+ if test -n "$withval"; then
+ AC_DEFINE_UNQUOTED(PROCDIR, "$withval", [Path of proc filesystem])
+ PROCDIR="$withval"
+ fi,
+ AC_DEFINE(PROCDIR, "/proc", [Path of proc filesystem]))
if test "x$cross_compiling" = xno; then
if test "x$enable_proc" = xyes; then
@@ -340,3 +332,20 @@ then
echo "****************************************************************"
echo ""
fi
+
+AC_MSG_RESULT([
+ ${PACKAGE_NAME} ${VERSION}
+
+ platform: $my_htop_platform
+ proc directory: $PROCDIR
+ openvz: $enable_openvz
+ cgroup: $enable_cgroup
+ vserver: $enable_vserver
+ ancient vserver: $enable_ancient_vserver
+ taskstats: $enable_taskstats
+ unicode: $enable_unicode
+ linux affinity: $enable_linux_affinity
+ hwlock: $enable_hwloc
+ setuid: $enable_setuid
+ linux delay accounting: $enable_delayacct
+])

© 2014-2024 Faster IT GmbH | imprint | privacy policy