aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene V. Lyubimkin <jackyf.devel@gmail.com>2009-03-29 19:49:53 +0300
committerDaniel Lange <DLange@git.local>2016-04-11 13:00:24 +0200
commitc06bd63994173cf367872ac3317331855c2ce5c6 (patch)
tree8e184e22ebf950c1c326e8f7efe2f008c0124662
parent375c6648cb948b3cd442b8609d63a42cd530fa0f (diff)
downloaddebian_htop-c06bd63994173cf367872ac3317331855c2ce5c6.tar.gz
debian_htop-c06bd63994173cf367872ac3317331855c2ce5c6.tar.bz2
debian_htop-c06bd63994173cf367872ac3317331855c2ce5c6.zip
Imported Debian patch 0.8.1-5debian/0.8.1-5
-rw-r--r--debian/changelog20
-rw-r--r--debian/control2
-rw-r--r--debian/patches/100-upstream-sort-by-processor-and-session.patch16
-rw-r--r--debian/patches/110-upstream-fix-page-size-on-BSD.patch37
-rw-r--r--debian/patches/120-upstream-explain-cpu-bars-in-monochrome-mode.patch18
-rw-r--r--debian/patches/600-openvz-veid-on-kernels-gt-2.6.18.patch1
-rw-r--r--debian/patches/610-rename-veid-to-ctid.patch1
-rw-r--r--debian/patches/800-tree-view-without-userland-threads.patch1
-rw-r--r--debian/patches/series3
9 files changed, 98 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e48512d..980ecca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,23 @@
+htop (0.8.1-5) unstable; urgency=low
+
+ * debian/patches:
+ - New 100-upstream-sort-by-processor-and-session.patch, cherry-picked from
+ upstream svn: allow sorting by 'processor' and 'session' columns.
+ (Closes: #501317)
+ - New debian/patches/110-upstream-fix-page-size-on-BSD.patch,
+ cherry-picked from upstream svn: fix page size on BSD systems.
+ (Closes: #485277)
+ - New debian/patches/120-upstream-explain-cpu-bars-in-monochrome-mode.patch,
+ cherry-picked from upstream svn: document meanings of chars in CPU bars
+ in monochrome mode. (Closes: #477222)
+ - 600-openvz-veid-on-kernels-gt-2.6.18.patch: added a description.
+ - 610-rename-veid-to-ctid.patch: added a description.
+ - 800-tree-view-without-userland-threads.patch: added a description.
+ * debian/control:
+ - Bump 'Standards-Version' to 3.8.1, no changes needed.
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sun, 29 Mar 2009 19:49:53 +0300
+
htop (0.8.1-4) unstable; urgency=low
* debian/patches:
diff --git a/debian/control b/debian/control
index 857d96c..dc19c05 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: utils
Priority: optional
Maintainer: Eugene V. Lyubimkin <jackyf.devel@gmail.com>
Build-Depends: debhelper (>= 7), libncurses5-dev, autotools-dev, quilt (>= 0.40), python-minimal
-Standards-Version: 3.8.0
+Standards-Version: 3.8.1
DM-Upload-Allowed: yes
Homepage: http://htop.sourceforge.net
diff --git a/debian/patches/100-upstream-sort-by-processor-and-session.patch b/debian/patches/100-upstream-sort-by-processor-and-session.patch
new file mode 100644
index 0000000..5dbbd1c
--- /dev/null
+++ b/debian/patches/100-upstream-sort-by-processor-and-session.patch
@@ -0,0 +1,16 @@
+Allow sorting by 'processor' and 'session' columns.
+Index: htop/Process.c
+===================================================================
+--- htop.orig/Process.c 2008-09-23 06:43:34.000000000 +0300
++++ htop/Process.c 2009-03-29 19:49:22.889032486 +0300
+@@ -533,6 +533,10 @@
+ return strcmp(p1->user, p2->user);
+ case PRIORITY:
+ return (p1->priority - p2->priority);
++ case PROCESSOR:
++ return (p1->processor - p2->processor);
++ case SESSION:
++ return (p1->session - p2->session);
+ case STATE:
+ return (p1->state - p2->state);
+ case NICE:
diff --git a/debian/patches/110-upstream-fix-page-size-on-BSD.patch b/debian/patches/110-upstream-fix-page-size-on-BSD.patch
new file mode 100644
index 0000000..e73fcb2
--- /dev/null
+++ b/debian/patches/110-upstream-fix-page-size-on-BSD.patch
@@ -0,0 +1,37 @@
+Fix page size on BSD systems.
+Index: htop/Process.c
+===================================================================
+--- htop.orig/Process.c 2009-03-29 20:03:00.601034016 +0300
++++ htop/Process.c 2009-03-29 20:03:56.029033456 +0300
+@@ -33,8 +33,9 @@
+ // This works only with glibc 2.1+. On earlier versions
+ // the behavior is similar to have a hardcoded page size.
+ #ifndef PAGE_SIZE
+-#define PAGE_SIZE ( sysconf(_SC_PAGESIZE) / 1024 )
++#define PAGE_SIZE ( sysconf(_SC_PAGESIZE) )
+ #endif
++#define PAGE_SIZE_KB ( PAGE_SIZE / ONE_K )
+
+ #define PROCESS_COMM_LEN 300
+
+@@ -351,13 +352,13 @@
+ : attr;
+ break;
+ }
+- case M_DRS: Process_printLargeNumber(this, str, this->m_drs * PAGE_SIZE); return;
+- case M_DT: Process_printLargeNumber(this, str, this->m_dt * PAGE_SIZE); return;
+- case M_LRS: Process_printLargeNumber(this, str, this->m_lrs * PAGE_SIZE); return;
+- case M_TRS: Process_printLargeNumber(this, str, this->m_trs * PAGE_SIZE); return;
+- case M_SIZE: Process_printLargeNumber(this, str, this->m_size * PAGE_SIZE); return;
+- case M_RESIDENT: Process_printLargeNumber(this, str, this->m_resident * PAGE_SIZE); return;
+- case M_SHARE: Process_printLargeNumber(this, str, this->m_share * PAGE_SIZE); return;
++ case M_DRS: Process_printLargeNumber(this, str, this->m_drs * PAGE_SIZE_KB); return;
++ case M_DT: Process_printLargeNumber(this, str, this->m_dt * PAGE_SIZE_KB); return;
++ case M_LRS: Process_printLargeNumber(this, str, this->m_lrs * PAGE_SIZE_KB); return;
++ case M_TRS: Process_printLargeNumber(this, str, this->m_trs * PAGE_SIZE_KB); return;
++ case M_SIZE: Process_printLargeNumber(this, str, this->m_size * PAGE_SIZE_KB); return;
++ case M_RESIDENT: Process_printLargeNumber(this, str, this->m_resident * PAGE_SIZE_KB); return;
++ case M_SHARE: Process_printLargeNumber(this, str, this->m_share * PAGE_SIZE_KB); return;
+ case ST_UID: snprintf(buffer, n, "%4d ", this->st_uid); break;
+ case USER: {
+ if (Process_getuid != this->st_uid)
diff --git a/debian/patches/120-upstream-explain-cpu-bars-in-monochrome-mode.patch b/debian/patches/120-upstream-explain-cpu-bars-in-monochrome-mode.patch
new file mode 100644
index 0000000..6bbc344
--- /dev/null
+++ b/debian/patches/120-upstream-explain-cpu-bars-in-monochrome-mode.patch
@@ -0,0 +1,18 @@
+Explain meaning of symbols in CPU bars in monochrome mode.
+Index: htop/htop.c
+===================================================================
+--- htop.orig/htop.c 2009-03-29 19:49:43.005032779 +0300
++++ htop/htop.c 2009-03-29 20:22:27.149033000 +0300
+@@ -99,8 +99,10 @@
+ addattrstr(CRT_colors[BAR_BORDER], "]");
+ attrset(CRT_colors[DEFAULT_COLOR]);
+ mvaddstr(6,0, "Type and layout of header meters are configurable in the setup screen.");
+- mvaddstr(7, 0, "Status: R: running; S: sleeping; T: traced/stopped; Z: zombie; D: disk sleep");
+-
++ if (CRT_colorScheme == COLORSCHEME_MONOCHROME) {
++ mvaddstr(7, 0, "In monochrome, meters are displayed through different chars, in order: |#*@$%&");
++ }
++ mvaddstr( 8, 0, " Status: R: running; S: sleeping; T: traced/stopped; Z: zombie; D: disk sleep");
+ mvaddstr( 9, 0, " Arrows: scroll process list F5 t: tree view");
+ mvaddstr(10, 0, " Digits: incremental PID search u: show processes of a single user");
+ mvaddstr(11, 0, " F3 /: incremental name search H: hide/show user threads");
diff --git a/debian/patches/600-openvz-veid-on-kernels-gt-2.6.18.patch b/debian/patches/600-openvz-veid-on-kernels-gt-2.6.18.patch
index 5826233..f510c5d 100644
--- a/debian/patches/600-openvz-veid-on-kernels-gt-2.6.18.patch
+++ b/debian/patches/600-openvz-veid-on-kernels-gt-2.6.18.patch
@@ -1,3 +1,4 @@
+Fix determining OpenVZ VEID on Linux kernels >= 2.6.18.
diff -Naur htop-0.8.1.orig/ProcessList.c htop-0.8.1/ProcessList.c
--- htop-0.8.1.orig/ProcessList.c 2008-09-23 08:23:14.000000000 +0200
+++ htop-0.8.1/ProcessList.c 2009-02-24 00:09:37.000000000 +0100
diff --git a/debian/patches/610-rename-veid-to-ctid.patch b/debian/patches/610-rename-veid-to-ctid.patch
index f2e7d43..d7258db 100644
--- a/debian/patches/610-rename-veid-to-ctid.patch
+++ b/debian/patches/610-rename-veid-to-ctid.patch
@@ -1,3 +1,4 @@
+Rename VEID->CTID.
diff -Naur htop-0.8.1.orig/Process.c htop-0.8.1/Process.c
--- htop-0.8.1.orig/Process.c 2008-09-23 05:43:34.000000000 +0200
+++ htop-0.8.1/Process.c 2009-02-24 00:11:35.000000000 +0100
diff --git a/debian/patches/800-tree-view-without-userland-threads.patch b/debian/patches/800-tree-view-without-userland-threads.patch
index 22c886d..db8c185 100644
--- a/debian/patches/800-tree-view-without-userland-threads.patch
+++ b/debian/patches/800-tree-view-without-userland-threads.patch
@@ -1,3 +1,4 @@
+Fix tree view when userland threads are hidden.
Index: htop/ProcessList.c
===================================================================
--- htop.orig/ProcessList.c 2009-02-25 23:08:35.396191440 +0200
diff --git a/debian/patches/series b/debian/patches/series
index e0acef1..19bb084 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,7 @@
010-make-desktop-file-valid.patch
+100-upstream-sort-by-processor-and-session.patch
+110-upstream-fix-page-size-on-BSD.patch
+120-upstream-explain-cpu-bars-in-monochrome-mode.patch
200-filter-non-printable-characters.patch
600-openvz-veid-on-kernels-gt-2.6.18.patch -p1
610-rename-veid-to-ctid.patch -p1

© 2014-2024 Faster IT GmbH | imprint | privacy policy