aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2021-01-11 20:51:12 +0100
committerDaniel Lange <DLange@git.local>2021-01-11 20:55:08 +0100
commit9c95b72c082f325f16001e89c3362c1d3cd0cf4c (patch)
tree7a083aff0bde7f86dbad031d1fcd7b3e1dc412a5
parent94123a215ba971baf4ad7e12cc479258ddb8600e (diff)
downloaddebian_htop-9c95b72c082f325f16001e89c3362c1d3cd0cf4c.tar.gz
debian_htop-9c95b72c082f325f16001e89c3362c1d3cd0cf4c.tar.bz2
debian_htop-9c95b72c082f325f16001e89c3362c1d3cd0cf4c.zip
Release 3.0.5-1debian/3.0.5-1
-rw-r--r--debian/changelog21
-rw-r--r--debian/patches/0001-Fix-broken-tree-display.patch78
-rw-r--r--debian/patches/0002-Fix-paussing-in-tree-mode.patch40
-rw-r--r--debian/patches/0003-Fix-kfreebsd-build.patch16
-rw-r--r--debian/patches/series3
5 files changed, 21 insertions, 137 deletions
diff --git a/debian/changelog b/debian/changelog
index 989bea8..a5d3853 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,24 @@
+htop (3.0.5-1) unstable; urgency=medium
+
+ * New upstream release 3.0.5
+ * Remove Debian patches upstreamed
+ * BUGFIX / SECURITY: InfoScreen: fix uncontrolled format string
+ * BUGFIX: Improve white text in the Light Terminal colour scheme
+ * Enable the function bar on the main screen to be hidden (see Setup -> Display options)
+ * BUGFIX: Reduce layout issues esp. around printing wide characters (not complete yet)
+ * BUGFIX: Make the follow function exit cleanly after followed process died
+ * Update help and man page for improved -t / -s options
+ * Drop usage of formatted error messages from <err.h>
+ * Show arrow indicating order of sorted process column
+ * Lots of plumbing around the internal Hashtable, hardening and code cleanups
+ * LibSensors: add support for Ryzen CPUs
+ * BUGFIX: Fix CPU percentage on M1 silicon Macs
+ * LoadMeter: dynamically adjust color and total of bar
+ * Enable going back to previous search matches (Shift-F3)
+ * Added keybind 'N' for sorting by PID (drops 'n'/'N' as not used before much)
+
+ -- Daniel Lange <DLange@debian.org> Mon, 11 Jan 2021 20:45:00 +0100
+
htop (3.0.3-2) unstable; urgency=medium
[ Daniel Lange ]
diff --git a/debian/patches/0001-Fix-broken-tree-display.patch b/debian/patches/0001-Fix-broken-tree-display.patch
deleted file mode 100644
index a86ca74..0000000
--- a/debian/patches/0001-Fix-broken-tree-display.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From c2cc7e2f348c10c4c39dbce43861882e10ef1b4f Mon Sep 17 00:00:00 2001
-From: Daniel Lange <DLange@git.local>
-Date: Fri, 11 Dec 2020 18:13:10 +0100
-Subject: [PATCH 1/2] Fix broken tree display
-
-upstream commits 4c44a70 and f6613db
----
- Process.c | 3 ++-
- ProcessList.c | 15 ++++++---------
- linux/LinuxProcess.c | 3 ++-
- 3 files changed, 10 insertions(+), 11 deletions(-)
-
-diff --git a/Process.c b/Process.c
-index 8245f86..927731b 100644
---- a/Process.c
-+++ b/Process.c
-@@ -320,7 +320,8 @@ void Process_writeField(const Process* this, RichString* str, ProcessField field
- buf += written;
- n -= written;
- }
-- const char* draw = CRT_treeStr[lastItem ? (this->settings->direction == 1 ? TREE_STR_BEND : TREE_STR_TEND) : TREE_STR_RTEE];
-+
-+ const char* draw = CRT_treeStr[lastItem ? TREE_STR_BEND : TREE_STR_RTEE];
- xSnprintf(buf, n, "%s%s ", draw, this->showChildren ? CRT_treeStr[TREE_STR_SHUT] : CRT_treeStr[TREE_STR_OPEN] );
- RichString_append(str, CRT_colors[PROCESS_TREE], buffer);
- Process_writeCommand(this, attr, baseattr, str);
-diff --git a/ProcessList.c b/ProcessList.c
-index 2d27339..e3199d2 100644
---- a/ProcessList.c
-+++ b/ProcessList.c
-@@ -479,23 +479,20 @@ void ProcessList_rebuildPanel(ProcessList* this) {
- int size = ProcessList_size(this);
- int idx = 0;
- for (int i = 0; i < size; i++) {
-- bool hidden = false;
- Process* p = ProcessList_get(this, i);
-
- if ( (!p->show)
- || (this->userId != (uid_t) -1 && (p->st_uid != this->userId))
- || (incFilter && !(String_contains_i(Process_getCommand(p), incFilter)))
- || (this->pidMatchList && !Hashtable_get(this->pidMatchList, p->tgid)) )
-- hidden = true;
-+ continue;
-
-- if (!hidden) {
-- Panel_set(this->panel, idx, (Object*)p);
-- if ((this->following == -1 && idx == currPos) || (this->following != -1 && p->pid == currPid)) {
-- Panel_setSelected(this->panel, idx);
-- this->panel->scrollV = currScrollV;
-- }
-- idx++;
-+ Panel_set(this->panel, idx, (Object*)p);
-+ if ((this->following == -1 && idx == currPos) || (this->following != -1 && p->pid == currPid)) {
-+ Panel_setSelected(this->panel, idx);
-+ this->panel->scrollV = currScrollV;
- }
-+ idx++;
- }
- }
-
-diff --git a/linux/LinuxProcess.c b/linux/LinuxProcess.c
-index 8298000..62837cb 100644
---- a/linux/LinuxProcess.c
-+++ b/linux/LinuxProcess.c
-@@ -605,8 +605,9 @@ static void LinuxProcess_writeCommandField(const Process *this, RichString *str,
- buf = stpcpy(buf, " ");
- }
- }
-+
- n -= (buf - buffer);
-- const char* draw = CRT_treeStr[lastItem ? (this->settings->direction == 1 ? TREE_STR_BEND : TREE_STR_TEND) : TREE_STR_RTEE];
-+ const char* draw = CRT_treeStr[lastItem ? TREE_STR_BEND : TREE_STR_RTEE];
- xSnprintf(buf, n, "%s%s ", draw, this->showChildren ? CRT_treeStr[TREE_STR_SHUT] : CRT_treeStr[TREE_STR_OPEN] );
- RichString_append(str, CRT_colors[PROCESS_TREE], buffer);
- LinuxProcess_writeCommand(this, attr, baseattr, str);
---
-2.25.1
-
diff --git a/debian/patches/0002-Fix-paussing-in-tree-mode.patch b/debian/patches/0002-Fix-paussing-in-tree-mode.patch
deleted file mode 100644
index b0cb959..0000000
--- a/debian/patches/0002-Fix-paussing-in-tree-mode.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 433ae89b72bc17b52dc98eac633cdf9903d1e7c5 Mon Sep 17 00:00:00 2001
-From: Daniel Lange <DLange@git.local>
-Date: Fri, 11 Dec 2020 18:16:12 +0100
-Subject: [PATCH 2/2] Fix paussing in tree mode
-
-Upstream commits 7b739b6 and db5687a
----
- Action.c | 2 ++
- ScreenManager.c | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/Action.c b/Action.c
-index 66934be..eccd985 100644
---- a/Action.c
-+++ b/Action.c
-@@ -273,6 +273,8 @@ static Htop_Reaction actionLowerPriority(State* st) {
-
- static Htop_Reaction actionInvertSortOrder(State* st) {
- Settings_invertSortOrder(st->settings);
-+ if (st->pauseProcessUpdate)
-+ ProcessList_sort(st->pl);
- return HTOP_REFRESH | HTOP_SAVE_SETTINGS;
- }
-
-diff --git a/ScreenManager.c b/ScreenManager.c
-index ac93721..94904b5 100644
---- a/ScreenManager.c
-+++ b/ScreenManager.c
-@@ -106,7 +106,7 @@ static void checkRecalculation(ScreenManager* this, double* oldTime, int* sortTi
- if (*rescan) {
- *oldTime = newTime;
- ProcessList_scan(pl, this->state->pauseProcessUpdate);
-- if (*sortTimeout == 0 || this->settings->treeView) {
-+ if (!this->state->pauseProcessUpdate && (*sortTimeout == 0 || this->settings->treeView)) {
- ProcessList_sort(pl);
- *sortTimeout = 1;
- }
---
-2.25.1
-
diff --git a/debian/patches/0003-Fix-kfreebsd-build.patch b/debian/patches/0003-Fix-kfreebsd-build.patch
deleted file mode 100644
index 2e4a630..0000000
--- a/debian/patches/0003-Fix-kfreebsd-build.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Fix kFreeBSD build
- Drop redundant sys/dirent.h include
-Forwarded: https://github.com/htop-dev/htop/pull/386
-Author: Graham Inggs <ginggs@debian.org>
-Last-Update: 2020-12-11
-
---- a/freebsd/FreeBSDProcessList.c
-+++ b/freebsd/FreeBSDProcessList.c
-@@ -14,7 +14,6 @@
- #include <stdlib.h>
- #include <string.h>
- #include <sys/_iovec.h>
--#include <sys/dirent.h>
- #include <sys/errno.h>
- #include <sys/param.h> // needs to be included before <sys/jail.h> for MAXPATHLEN
- #include <sys/jail.h>
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 57977ec..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,3 +0,0 @@
-0001-Fix-broken-tree-display.patch
-0002-Fix-paussing-in-tree-mode.patch
-0003-Fix-kfreebsd-build.patch

© 2014-2024 Faster IT GmbH | imprint | privacy policy